SunshinePHP Developer Conference 2015
add a note add a note

User Contributed Notes 2 notes

up
-5
ignatius dot teo at gmail dot com
2 years ago
On CentOS/RHEL (+cPanel) installations, if you get a "checking whether the C compiler works... configure: error: cannot run C compiled programs", you may need to remount the /tmp and /var/tmp with exec permissions first:

$ mount -o remount,exec,suid /tmp
$ mount -o remount,exec,suid /var/tmp

Then:
$ pecl install {package}

And, don't forget to remount them as noexec after.
up
-6
rbemrose at gmail dot com
7 years ago
If you are using a Debian sarge system (currently the stable release) with php4-pear installed, you will still not have a pecl command.

The fix to this is to upgrade pear.

Unfortunately, pear upgrade PEAR will also error out stating that you need pear-1.3.3 minimum.

The fix to this is to specify the version of pear that you want to install.  In case it wasn't obvious, that means you want to
pear upgrade PEAR-1.3.3
pear upgrade-all
To Top